Skip to content
securitytabs

Updated · 1 update

GitLab Patches Maximum-Severity Flaw; CISA Says It Is Exploited

GitLab has fixed a serious flaw that could let an attacker take over servers running the GitLab code-hosting software, and the US cyber agency now lists it as being used in attacks. Organizations that run their own GitLab should update now.

Written by the SecurityTabs AI newsroom from 5 outlets, every paragraph cited; vulnerability scores come from NVD, FIRST and CISA, not the AI.

What's new

  1. CISA added the flaw to its Known Exploited Vulnerabilities catalogue on October 29, and the Canadian Centre for Cyber Security updated its advisory to say so. [1][2]

TimelineWhat should my organization do?

Vulnerabilities

What happened

On October 12, 2026, GitLab released versions 19.4.2, 19.3.5 and 19.2.8 to fix CVE-2026-97229, according to Rapid7. Rapid7 describes it as an integer overflow, a calculation error, in the way GitLab handles regular expressions (text-matching patterns) in its CI/CD configuration, the files that automate building and testing software. [3][4][5]

Rapid7 says that under certain conditions a remote attacker can run code on a GitLab server through a specially crafted regular expression stored in a malicious CI/CD configuration. The issue was reported through HackerOne by a researcher named joaxcar, according to Rapid7. [3][4]

Severity and affected versions

GitLab assigned the flaw a CVSS severity score of 10.0, the maximum, and NVD lists the same score. Rapid7 says the vendor score implies exploitation without logging in, and notes that GitLab says all deployment types are affected unless stated otherwise. It lists GitLab Community Edition and Enterprise Edition from 19.2 before 19.2.8, 19.3 before 19.3.5 and 19.4 before 19.4.2 as affected. Rapid7 says GitLab.com was patched before disclosure. [3][4]

Exploitation

CISA added the flaw on October 29 to its Known Exploited Vulnerabilities (KEV) catalogue, its list of flaws attackers are using, citing evidence of active exploitation. The Canadian Centre for Cyber Security updated its GitLab advisory the same day to note the listing. [1][2]

The Hacker News reports that an attacker tried to exploit the flaw on the Alpine Linux project's own GitLab server about a week after the fix was released, according to Alpine Linux, which said so on October 28. Alpine found no evidence that the attack worked, according to the report. [6]

What is not yet known

The coverage reviewed does not say how widespread exploitation is or who is behind it. Rapid7 notes the vendor's score and its own reproduction of the flaw may differ on whether authentication is needed. [3][1]

Timeline

  1. · CISA KEV

    CISA added CVE-2026-97229 to its Known Exploited Vulnerabilities catalog.

  2. Alpine Linux said an attacker had tried to exploit the flaw on its GitLab server. [6]

  3. Rapid7 published a technical analysis of the regular expression handling flaw. [4]

  4. Rapid7 published an advisory describing the flaw as critical. [3]

  5. GitLab released versions 19.4.2, 19.3.5 and 19.2.8 to fix the flaw. [3][4]

Update history

  1. CISA added the flaw to its Known Exploited Vulnerabilities catalogue on October 29, and the Canadian Centre for Cyber Security updated its advisory to say so. [1][2]

  2. First published

Explained

The technology and terms in this story. Learn more

Why it was possible

The weaknesses behind this story's CVEs, from each CVE Record.

Business ActionWhat this means inside your organization, and what to do about it, by company size.

Small business

No dedicated security staff; relies on providers

What to know

If you use GitLab.com, Rapid7 says it was patched before disclosure. If an IT provider or developer runs a GitLab server for you, it needs the fixed version, and CISA says the flaw is being exploited. [4][1]

What to do

  1. Ask whoever runs your GitLab whether it has been updated to 19.4.2, 19.3.5, 19.2.8 or later. [4]
  2. Ask your provider whether it has checked for signs of attempted exploitation, since an attempt has been reported and CISA lists the flaw as exploited. [6][1]

Mid-size company

A small IT or security team

What to know

Self-managed GitLab CE and EE in the 19.2, 19.3 and 19.4 lines are affected until updated. CISA lists the flaw as exploited and an attempted attack has been reported against another project's server. [4][1][6]

What to do

  1. Identify self-managed GitLab servers and upgrade to 19.4.2, 19.3.5 or 19.2.8 or later. [4]
  2. Review recent CI/CD configuration changes and server logs for unexpected activity since the fix was released. [6][3]

Large enterprise

A security operations team

What to know

Rapid7 rates this a critical unauthenticated code execution risk on GitLab CE and EE. CISA has added it to its exploited-flaws catalogue, and Alpine Linux reports an unsuccessful attempt against its own server. [3][1][6]

What to do

  1. Inventory all self-managed GitLab instances, including those run by teams outside central IT, and upgrade to the fixed releases. [4]
  2. Hunt through GitLab and web logs for attempts involving crafted CI/CD configurations from the time of the fix onward. [6][3]

Sources

  1. [1]CISA Advisories · Oct 29, 12:00 UTC
    CISA Adds Two Known Exploited Vulnerabilities to Catalogcontext
  2. [2]Canadian Centre for Cyber Security · Oct 29, 20:14 UTC
    GitLab security advisory (AV26-1028) - Update 1context
  3. [3]Rapid7 Blog · Oct 13, 11:29 UTC
    CVE-2026-97229: Critical Unauthenticated Remote Code Execution in GitLabcontext
  4. [4]Rapid7 Blog · Oct 16, 13:31 UTC
    Rapid7 Analysis: GitLab CI/CD Regex Integer Overflow (CVE-2026-97229)context
  5. [5]SANS Internet Storm Center StormCast · Oct 13, 02:00 UTC
    SANS Stormcast Tuesday, October 13th, 2026: GitLab CI/CD RCE (CVE-2026-97229); Let’s Encrypt 64-Day Certificates; Midnight Mimosa Pre-Installed Android Malware; Progress MarkLogic Patchescontext
  6. [6]The Hacker News · Oct 29, 09:05 UTC
    Attacker Tried to Exploit Alpine Linux’s GitLab via CVSS 10.0 Flaw Its Ruby Left Opencontext